<?xml version="1.0" encoding="UTF-8"?>
<rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom"><channel><title>VulnFeed.org: agentscope-ai AgentScope</title><link>https://vulnfeed.org/</link><description>Every disclosure, as it lands. Critical-only feed available.</description><language>en</language><atom:link href="https://vulnfeed.org/feed/product/agentscope-ai-agentscope.xml" rel="self" type="application/rss+xml"/><item><title>CVE-2026-123022: agentscope-ai AgentScope MCP Workspace API _config.py subprocess.Popen os command injection</title><link>https://vulnfeed.org/cve/CVE-2026-123022/</link><guid isPermaLink="true">https://vulnfeed.org/cve/CVE-2026-123022/</guid><pubDate>Thu, 05 Nov 2026 14:17:04 +0000</pubDate><description>A vulnerability was detected in agentscope-ai AgentScope up to 2.0.11. The impacted element is the function subprocess.Popen of the file src/agentscope/mcp/_config.py of the component MCP Workspace API. The manipulation of the argument command results in os command injection. The attack may be launched remotely. The exploit is now public and may be used. The pull request to fix this issue awaits acceptance.</description></item><item><title>CVE-2026-123023: agentscope-ai AgentScope Bash Tool _bash.py check_permissions authorization</title><link>https://vulnfeed.org/cve/CVE-2026-123023/</link><guid isPermaLink="true">https://vulnfeed.org/cve/CVE-2026-123023/</guid><pubDate>Thu, 05 Nov 2026 14:17:04 +0000</pubDate><description>A flaw has been found in agentscope-ai AgentScope up to 2.0.8. This affects the function check_permissions of the file src/agentscope/tool/_builtin/_bash.py of the component Bash Tool. This manipulation causes incorrect authorization. Remote exploitation of the attack is possible. The exploit has been published and may be used. Upgrading to version 2.0.9 mitigates this issue. Patch name: 6b43b13a46401e86abd3defeed9a8bfe5b37bc6d. It is recommended to upgrade the affected component.</description></item><item><title>CVE-2026-123024: agentscope-ai AgentScope Agent Service deps.py get_current_user_id missing authentication</title><link>https://vulnfeed.org/cve/CVE-2026-123024/</link><guid isPermaLink="true">https://vulnfeed.org/cve/CVE-2026-123024/</guid><pubDate>Thu, 05 Nov 2026 14:17:04 +0000</pubDate><description>A vulnerability has been found in agentscope-ai AgentScope up to 2.0.11. This impacts the function get_current_user_id of the file src/agentscope/app/deps.py of the component Agent Service. Such manipulation of the argument X-User-ID leads to missing authentication. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. The pull request to fix this issue awaits acceptance.</description></item></channel></rss>
